Перейти к содержанию

Поддерживаемые платформы

Необходимые условия для установки

Чтобы установить WAF‑ноду, вам необходимы:

  • Поддерживаемая платформа
  • Возможность выполнять команды с правами root
  • Аккаунт Валарм в RU‑облаке или EU‑облаке

WAF‑нода Валарм может быть установлена на следующие платформы:

  • NGINX и NGINX Plus

    Интеграция WAF‑ноды с NGINX или NGINX Plus осуществляется с помощью нескольких модулей.

    Существует несколько вариантов установки модулей. Выбор конкретного варианта зависит от того, каким образом был установлен NGINX или NGINX Plus.

    Также вы можете развернуть WAF‑ноду с помощью Docker. Контейнер с WAF‑нодой содержит в себе все необходимые модули.

    Поддерживаемые операционные системы

    Модули Валарм могут быть установлены на следующие операционные системы:

    • Debian 8.x (jessie)
    • Debian 9.x (stretch)
    • Debian 10.x (buster)
    • Ubuntu 14.04 LTS (trusty)
    • Ubuntu 16.04 LTS (xenial)
    • Ubuntu 18.04 LTS (bionic)
    • CentOS 6.x
    • CentOS 7.x
    • Amazon Linux 2

    Требования к разрядности операционной системы

    Установка модулей возможна только на 64-битные операционные системы.

  • Кластер Kubernetes

    Поддержка платформы Kubernetes

    Обратите внимание, что Ingress‑контроллеры NGINX или NGINX Plus Валарм работают только на платформе Kubernetes версии 1.15 и ниже.

    Вы можете установить WAF‑ноду в кластере Kubernetes в следующих вариантах:

  • Облачные платформы:

  • Kong (инструкция по установке)

    Поддерживаемые операционные системы

    Для работы с модулями Валарм платформа Kong должна иметь версию 1.4.3 или ниже и должна быть установлена на операционную систему из следующего списка:

    • Debian 8.x (jessie)
    • Debian 9.x (stretch)
    • Ubuntu 14.04 LTS (trusty)
    • Ubuntu 16.04 LTS (xenial)
    • Ubuntu 18.04 LTS (bionic)
    • CentOS 6.x
    • CentOS 7.x